Multimedia Aviation Medical Examiner Refresher Course (MAMERC)

Improvements in this version include the functionality to operate across all operating systems and browsers. You now have the ability to log onto your account, view course enrollments and completions, and print certificates. The minimum version of the Flash Player browser plug-in required to use MAMERC is Flash 6.0.79.

MAMERC requires that you create an account using a valid email address and your AME number. If your five-digit AME number includes leading zeroes (i.e. 00999), please include leading zeroes when registering.


New users
Returning users